Opened 13 years ago

Closed 11 years ago

#99 closed enhancement (fixed)

Change BuildMaster UI so it can "cancel queued jobs"

Reported by: joduinn Owned by: nhemingway
Priority: minor Milestone: 0.8.+
Version: 0.7.5 Keywords:
Cc:

Description

We accidently clicked twice on the buildbot, which means we have two jobs queued up to be handed out to slaves.

One is being processed by a slave, and we could stop that job-in-progress by the UI. However, there is no way to stop the 2nd queued job.

Attachments (2)

Queue.diff (11.6 KB) - added by cli 12 years ago.
Patch that might introduce some of the features requested here.
first_steps_to_99.patch (16.6 KB) - added by nhemingway 12 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 13 years ago by warner

  • component changed from other to buildprocess

yeah, we really need a web page to control those queues.

For this particular situation, if the builds were identical, you could kill the first build and then just let the second one run to completion. But in general, we need a way to both remove and accelerate jobs from the scheduler's queue, and to remove buildrequests from the Builder's queue.

comment:2 Changed 13 years ago by warner

#30 was a duplicate of this one #93 was too

comment:3 Changed 13 years ago by warner

  • Milestone changed from undecided to 0.7.7

comment:4 Changed 13 years ago by warner

  • Milestone changed from 0.7.7 to 0.7.8

no progress on this yet, bumping to 0.7.8

comment:5 Changed 13 years ago by bhearsum

  • Cc bhearsum@… added

comment:6 Changed 13 years ago by warner

  • Milestone changed from 0.7.8 to 0.7.9

I'd like this, but we don't have any code for it yet. Bumping to 0.7.9

comment:7 Changed 12 years ago by nhemingway

  • Owner set to nhemingway
  • Status changed from new to assigned

Changed 12 years ago by cli

Patch that might introduce some of the features requested here.

comment:8 Changed 12 years ago by nhemingway

first_steps_to_99.patch takes Christian's patch, remove stuff that I think is specific to his instance, and adds tests and documentation (tho the doc is only a partial line).

I've also committed it as 0edd56ddb2ec5f46217241d7ba1408dafdd98914 to one-oh at repo.or.cz

Finally, apologies for some of the logging that I inadvertantly left in. I'll remove it in a later commit.

Changed 12 years ago by nhemingway

comment:9 Changed 12 years ago by dustin

  • Milestone changed from 0.8.0 to 0.7.+

comment:10 Changed 12 years ago by dustin

Do you want to try to get this set up for 0.7.10?

comment:11 Changed 12 years ago by bhearsum

  • Cc bhearsum@… removed

comment:12 Changed 11 years ago by bhearsum

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.