Opened 10 years ago

Closed 10 years ago

#947 closed defect (fixed)

cycler(..) not available in Jinja-2.0

Reported by: dustin Owned by:
Priority: major Milestone: 0.8.2
Version: 0.8.1 Keywords: web
Cc:

Description

This method was added in Jinja-2.1:

http://jinja.pocoo.org/2/documentation/templates#cycler

Options:

  1. increase Jinja requirement to 2.1
  2. replace this with loop.cycle or manual specification of classes
  3. bundle an implementation of the class

Change History (2)

comment:1 Changed 10 years ago by dustin

It looks like 2.1 and higher have been available for quite a while, so I think we should just require 2.1.

comment:2 Changed 10 years ago by Dustin J. Mitchell

  • Resolution set to fixed
  • Status changed from new to closed

Increase required version of Jinja to 2.1

Fixes #947

Changeset: df56ce81ee7d5186e0fbb8e06987ddf0295da904

Note: See TracTickets for help on using tickets.