Opened 8 years ago

Closed 7 years ago

#905 closed defect (fixed)

Cannot install Buildbot 0.8.0 on Windows 7

Reported by: rstackhouse Owned by:
Priority: major Milestone: 0.8.+
Version: 0.8.0 Keywords: windows
Cc:

Description (last modified by dustin)

I tried installing Buildbot through easy_install (Python 2.6) and got the following message:

C:>easy_install buildbot
Searching for buildbot
Reading http://pypi.python.org/simple/buildbot/
Reading http://buildbot.net/
Reading https://sourceforge.net/project/showfiles.php?group_id=73177&package_id=
73212&release_id=665379
Reading http://buildbot.sourceforge.net/
Best match: buildbot 0.8.0
Downloading http://pypi.python.org/packages/source/b/buildbot/buildbot-0.8.0.zip
#md5=be3cdbbf2de256547c7daadf8d899d3d
Processing buildbot-0.8.0.zip
Running buildbot-0.8.0setup.py -q bdist_egg --dist-dir c:users
obert~2appdatalocal	empeasy_install-lsccanuildbot-0.8.0egg-dist-tmp-v9ygu6
zip_safe flag not set; analyzing archive contents...
buildbot.clients.debug: module references __file__
buildbot.scripts.runner: module references __file__
No eggs found in c:users
obert~2appdatalocal	empeasy_install-lsccanuildbot-0.8.0egg-dist-tmp-v9ygu6 (setup script problem?)

Then, I tried installing from zip using "python setup.py install" and got the following message:

C:uildbot-0.8.0>python setup.py install
running install
running bdist_egg
running egg_info
writing requirements to buildbot.egg-info
equires.txt
writing buildbot.egg-infoPKG-INFO
writing top-level names to buildbot.egg-info	op_level.txt
writing dependency_links to buildbot.egg-infodependency_links.txt
reading manifest file 'buildbot.egg-infoSOURCES.txt'
reading manifest template 'MANIFEST.in'
warning: no files found matching 'README'
warning: no files found matching 'NEWS'
warning: no files found matching 'CREDITS'
warning: no files found matching 'COPYING'
warning: no files found matching 'UPGRADING'
warning: no files found matching 'docsimagesMakefile'
warning: no files found matching 'docsepyrun'
warning: no files found matching 'docsgen-reference'
warning: no files found matching 'docsMakefile'
writing manifest file 'buildbot.egg-infoSOURCES.txt'
installing library code to builddist.win32egg
running install_lib
running build_py
installing package data to builddist.win32egg
running install_data
installing scripts to builddist.win32eggEGG-INFOscripts
running install_scripts
running build_scripts
error: file 'C:uildbot-0.8.0inuildbot' does not exist

Change History (9)

comment:1 Changed 8 years ago by maruel

You can look at http://buildbot.net/trac/wiki/MetaBuildbotConfig to see how much I fought to install buildbot ...

Feel free to update the wiki page since I think I missed some parts.

comment:2 Changed 8 years ago by dustin

  • Description modified (diff)

edit formatting

comment:3 Changed 8 years ago by dustin

  • Milestone changed from undecided to 0.8.2
  • Type changed from undecided to defect

Robert - if you can test the latest on master, that would be great. The focus at the moment is getting the *slave* running on Windows, but the master should run, too -- just not on cygwin.

comment:4 Changed 8 years ago by TimothyFitz

Both the 0.8.1 master and the slave installed cleanly for me on Windows 7 (not cygwin).

comment:5 Changed 8 years ago by dustin

Can we boil this down into some documentation, either on the wiki or in the texinfo?

comment:6 Changed 8 years ago by dustin

  • Milestone changed from 0.8.2 to 0.8.3

comment:7 Changed 8 years ago by fatman

I can confirm that I was able to install a Buildbot slave package on Windows 7 Ultimate, though not without a bit of hacking on my part. At the time, the instructions in http://buildbot.net/trac/wiki/RunningBuildbotOnWindows were a little outdated. (I could add more, but it is offtopic, ie. not Windows 7 related.)

The Windows 7 buildslave works fine (although I need to tweak the build environment somewhat).

comment:8 Changed 8 years ago by dustin

fatman - I see that you made some changes to RunningBuildbotOnWindows - is there anything else we need to do here?

comment:9 Changed 7 years ago by ayust

  • Milestone changed from 0.8.3 to 0.8.+
  • Resolution set to fixed
  • Status changed from new to closed

Going to close this as resolved; reopen if there are further issues.

Note: See TracTickets for help on using tickets.