Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#742 closed defect (worksforme)

A "reconfig" invalidates build state display in /builders

Reported by: tfogal Owned by: dustin
Priority: major Milestone: 0.8.0
Version: master Keywords:
Cc:

Description

In df0a02ffd6207cc2e888411919457d283fde487e, if you've got slaves in the middle of a compile and you run a buildbot reconfig on the master, then loading up http://hostname:8010/builders/ says that the builders are idle.

If you click a builder and thus go to the builder's status page, the build is properly listed under the "Current Builds", and is proceeding as specified / fine.

Change History (4)

comment:1 Changed 10 years ago by dustin

  • Milestone changed from undecided to 0.8.0
  • Priority changed from trivial to major

comment:2 Changed 10 years ago by dustin

  • Owner set to dustin
  • Status changed from new to assigned

comment:3 Changed 10 years ago by dustin

  • Resolution set to worksforme
  • Status changed from assigned to closed

Hmm, I just tried this and didn't find any problem -- the builder stays marked as yellow/"building" until it finishes, at which point the builder goes to "idle"

A lot has changed since March 11..

Can you retry with the newest and reopen if it's still a problem?

comment:4 Changed 10 years ago by tfogal

Confirmed fixed. I just tested with 0.8.0's HEAD and it seems to be working now.

Note: See TracTickets for help on using tickets.