Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#551 closed defect (fixed)

my step name is getting used in a URL without being escaped

Reported by: offby1 Owned by:
Priority: minor Milestone: undecided
Version: 0.7.8 Keywords:
Cc:

Description

I recently renamed one of my build steps from "lint" to "lint/check". Note the slash. Soon after, someone broke the build in that step, and when they clicked on the relevant link in their browser, they were sent to a URL that ended with "lint/check", and their browser displayed an error to the effect of "no such resource". I suspect the problem is simply that someone is forgetting to URL-escape the step.

In any case, I attempted to work around the problem by renaming the step so that it doesn't include a slash.

Change History (4)

comment:1 Changed 11 years ago by offby1

Yeah, I just revisted the URL, and manually replaced the / with a %2f, and that showed me the page I originally wanted to see.

If it matters, here is the original URL (with the host name redacted):

http://xxx:8010/builders/Python-2.6.1_trunk_build/builds/56/steps/lint/check/logs/stdio

Changing that to

http://xxx:8010/builders/Python-2.6.1_trunk_build/builds/56/steps/lint%2fcheck/logs/stdio

lets me see the log.

comment:2 Changed 10 years ago by dustin

  • Resolution set to fixed
  • Status changed from new to closed

I *think* this is fixed in [32da8976f77f5a958211b4a2adb533064eba5f11].

comment:3 Changed 10 years ago by offby1

It seems unlikely that that patch fixes the problem, since it went in in January 2006, whereas the release in which I found the problem (according to http://buildbot.net/trac/milestone/0.7.8) was made in July 2008.

comment:4 Changed 10 years ago by dustin

Well, it's definitely fixed now. You should upgrade.

122                         req.childLink("steps/%s" % urllib.quote(name)),
Note: See TracTickets for help on using tickets.