Opened 10 years ago

Closed 10 years ago

#550 closed defect (duplicate)

Zombie process (<defunc>) happening a lot under FreeBSD 7.1

Reported by: WildChild Owned by:
Priority: critical Milestone: undecided
Version: 0.7.10 Keywords:
Cc:

Description

I started noticing that when I configured a slave buildbot for the PyPy? project under FreeBSD 7.1. I now have configured a Buildbot network with a FreeBSD master and slave and a Linux slave.

The problem is that under FreeBSD, every steps of the build factory leave a zombie process for a while after the command execution ended. On the web interface, I get from "stdout" that the execution ended but Buildbot didn't detect it. This zombie process usually sticks for between 30 secs and 10 minutes before Buildbot detects that the command ended. Starting a build with 4-5 steps then takes a very long time to complete.

Under Linux, the same build with the 4-5 steps takes between 4 to 5 seconds to complete, with no zombie process appearing.

Any workaround?

Change History (1)

comment:1 Changed 10 years ago by thatch

  • Resolution set to duplicate
  • Status changed from new to closed

This appears to be the same as #192, and I'm not aware of a workaround.

Note: See TracTickets for help on using tickets.