Opened 12 years ago

Closed 12 years ago

#432 closed enhancement (duplicate)

Pending builds should be built in order

Reported by: cfoote Owned by:
Priority: major Milestone: undecided
Version: 0.7.9 Keywords:
Cc:

Description

When using a buildslave that is set to have a max_builds=1, the Pending builds for the slave are build in the order that the builders are listed. So when changes arrive while a build is happening, the first builder gets a re-started with the new change before other builders that have pending builds from the previous change have been built.

I think that it would be better if the Pending builds where performed in the order that they were added (ie. FIFO queue).

Change History (2)

comment:1 Changed 12 years ago by bhearsum

I'm pretty sure this is fixed in http://github.com/djmitche/buildbot/commit/36ea32f4c2a9515037921f7a618ff5d00a6a6e3d - which will be included in 0.7.10.

comment:2 Changed 12 years ago by bhearsum

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of http://buildbot.net/trac/ticket/334, which is closed.

Note: See TracTickets for help on using tickets.