Opened 9 years ago

Last modified 3 years ago

#420 reopened defect

slash not escaped in url links when builder name contains slash inside

Reported by: arekm Owned by: djmitche
Priority: minor Milestone: 0.8.x
Version: 0.8.10 Keywords: web
Cc: arekm, ido@…

Description (last modified by dustin)

When using builder names with slash inside like

builderNames=PLD/Linux Th?

then web interface contains links "/builders/PLD/Linux%20Th/builds/101" where the correct link should be "/builders/PLD%2fLinux%20Th/builds/101" (note slash escaped with %2f)

Change History (7)

comment:1 Changed 9 years ago by dustin

  • Milestone changed from undecided to 0.7.10

comment:2 Changed 9 years ago by nhemingway

  • Cc arekm added
  • Keywords review added
  • Owner set to djmitche

comment:3 Changed 9 years ago by dustin

  • Resolution set to fixed
  • Status changed from new to closed

Great - thanks!

commit 5bd3d78c613ac9fff056e7e2c12783fc1fe9bd82
Merge: 6dab63a... 71c3097...
Author: Dustin J. Mitchell <>
Date:   Sun Feb 22 08:53:09 2009 -0500

    Merge branch 'bug420' of git://

comment:4 Changed 3 years ago by ido

Hi Dustin, long time no see, just wanted to reopen this briefly since I found unescaped/unquoted slashes in the /buildslaves page in the builder_column that lists the builders that use each buildslave in the list:

There's an issue in the /buildslaves page.

Backend =

Template =

I've only confirmed the issue with 0.8.10, not with the nine branch (I am only running eight).

Steps to replicate:

  1. Create a buildslave.
  2. Create a builder with a slash (/) in its name, e.g. "abc/xyz/123".
  3. Go to the buildbot master's web, click on the "Buildslaves" link in the header, which in my case takes you to http://localhost:8010/buildslaves
  4. Click on the builder's link (abc/xyz/123) in the appropriate buildslave's row on that page.
  5. It will take you to http://localhost:8010/builders/abc/xyz/123 (rather than http://localhost:8010/builders/abc%2Fxyz%2F123), resulting in a 404 No Such Resource error when you click on the builder column link from the /buildslaves page. This is because b.path_to_builder is not used to generate the links to the builder's page in /buildslaves.

comment:5 Changed 3 years ago by dustin

  • Description modified (diff)
  • Keywords web added; review removed
  • Milestone changed from 0.7.10 to 0.8.x

That's been rewritten in nine, but is certainly something that could be addressed in eight.

comment:6 Changed 3 years ago by ido

Since it was partially fixed in an earlier version of seven/eight (see above), but not consistently so (i.e. buildslave page), seems reasonable to hotfix it.

comment:7 Changed 3 years ago by ido

  • Cc ido@… added
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 0.7.9 to 0.8.10
Note: See TracTickets for help on using tickets.