Opened 4 years ago

Closed 3 years ago

#3408 closed defect (fixed)

building documentation with Sphinx v1.3.4 generates warning "unknown option: -p"

Reported by: rutsky Owned by:
Priority: major Milestone: undecided
Version: master Keywords: simple
Cc:

Description

Example build: https://travis-ci.org/buildbot/buildbot/jobs/101957859#L663

This issue will break all Travis builds.

With sphinx 1.3.3 no warnings are generated.

Change History (7)

comment:1 Changed 4 years ago by dustin

  • Cc tardyp added

Pierre, I think you upgraded sphinx recently? Did you see something like this?

comment:2 Changed 4 years ago by rutsky

I pushed workaround in my branch: https://github.com/rutsky/buildbot/commit/07373535038b0fb339ff37be8357840d647f3edb

It can be cherry-picked for master.

comment:3 Changed 4 years ago by rutsky

I don't want to investigate this issue at this moment.

comment:4 Changed 4 years ago by dustin

  • Cc tardyp removed
  • Owner set to dustin
  • Status changed from new to assigned

comment:5 Changed 3 years ago by dustin

  • Keywords simple added
  • Owner dustin deleted

comment:6 Changed 3 years ago by rutsky

Looks like this was Sphinx bug, with Sphinx 1.4.* this issue is not reproduced.

PR that unpins Sphinx version: https://github.com/buildbot/buildbot/pull/2147

comment:7 Changed 3 years ago by rutsky

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.