Opened 5 years ago

Closed 4 years ago

#3366 closed defect (duplicate)

Problems caused by caching build requests

Reported by: ian Owned by:
Priority: major Milestone: 0.9.+
Version: master Keywords:
Cc:

Description

I have a config where I might different generate 'changes' for the same revision at different times. In particular, it is the dictionary of properties attached to the change which is likely to differ.

When I tried this, I seemed to be getting old dictionaries in the new changes. As far as I can tell there was some caching going on, I think of 'build request's, I think based on 'ssid'.

I tried moving the revision into the properties dictionary and setting the revision to None, but even then I seemed to be getting properties cached for the None ssid.

Finally I set the revision to str(properties) and that worked around the problem.

I don't fully understand what's being cached, how or why, but I would expect that at the very least changes with revision None would not be cached, and ideally the properties would be taken into account with the caching.

Change History (3)

comment:1 Changed 5 years ago by ian

comment:2 Changed 4 years ago by tardyp

  • Milestone changed from 0.9.0 to 0.9.+

a ssid is generated given the following hashed informations:

ss_hash = self.hashColumns(branch, revision, repository, project,

codebase, patchid)

So it is by design that if you reuse the same (branch, revision, repository, project, codebase, patchid), then you will get the same ssid.

I am not sure exactly what is your usecase, but I think the properties you are willing to change are rather belonging to the buildset than the change.

-- marking it non blocking for the release

comment:3 Changed 4 years ago by tardyp

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.