Opened 5 years ago

Closed 5 years ago

#3172 closed defect (duplicate)

traceback at nine.bb.net

Reported by: sa2ajj Owned by:
Priority: major Milestone: 0.9.0
Version: master Keywords: web
Cc: tardyp, Ben

Description

2015-01-24 04:39:40+0000 [-] while handling API request
        Traceback (most recent call last):
          File "/home/bbuser/venv/lib/python2.7/site-packages/twisted/internet/defer.py", line 1097, in _inlineCallbacks
            result = result.throwExceptionIntoGenerator(g)
          File "/home/bbuser/venv/lib/python2.7/site-packages/twisted/python/failure.py", line 389, in throwExceptionIntoGenerator
            return g.throw(self.type, self.value, self.tb)
          File "/usr/home/bbuser/buildbot/master/buildbot/www/rest.py", line 374, in renderRest
            request.write(data)
          File "/usr/local/lib/python2.7/contextlib.py", line 35, in __exit__
            self.gen.throw(type, value, traceback)
        --- <exception caught here> ---
          File "/usr/home/bbuser/buildbot/master/buildbot/www/rest.py", line 111, in handleErrors
            yield
          File "/usr/home/bbuser/buildbot/master/buildbot/www/rest.py", line 308, in renderRest
            data = yield ep.get(rspec, kwargs)
          File "/home/bbuser/venv/lib/python2.7/site-packages/twisted/internet/defer.py", line 1097, in _inlineCallbacks
            result = result.throwExceptionIntoGenerator(g)
          File "/home/bbuser/venv/lib/python2.7/site-packages/twisted/python/failure.py", line 389, in throwExceptionIntoGenerator
            return g.throw(self.type, self.value, self.tb)
          File "/usr/home/bbuser/buildbot/master/buildbot/data/changes.py", line 73, in get
            changes = yield self.master.db.changes.getChangesForBuild(buildid)
          File "/home/bbuser/venv/lib/python2.7/site-packages/twisted/internet/defer.py", line 1099, in _inlineCallbacks
            result = g.send(result)
          File "/usr/home/bbuser/buildbot/master/buildbot/db/changes.py", line 191, in getChangesForBuild
            while ((toChanges.get(cb, {}).get('changeid') not in change['parent_changeids']) and
        exceptions.TypeError: 'NoneType' object has no attribute '__getitem__'

Change History (1)

comment:1 Changed 5 years ago by Ben

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3071

Note: See TracTickets for help on using tickets.