Opened 6 years ago

Closed 6 years ago

#3158 closed enhancement (duplicate)

Rest api for rebuild

Reported by: tardyp Owned by: shenal
Priority: major Milestone: 0.9.0
Version: master Keywords:
Cc:

Description

Rebuild functionality should be recreated for nine.

  • Copy the buildset into a new buildset, with the same properties, and same sourcestamp
  • Create a single buildrequest on this buildset for the original build's builder.

Avoid reproducing the mistakes of eight, so dont use the build properties for rebuild. They could have changed during build. Use "buildset" properties

Change History (3)

comment:1 Changed 6 years ago by sa2ajj

  • Milestone changed from undecided to 0.9.0
  • Type changed from undecided to enhancement
  • Version changed from 0.8.10 to master

comment:2 Changed 6 years ago by shenal

  • Owner set to shenal
  • Status changed from new to accepted

comment:3 Changed 6 years ago by dustin

  • Resolution set to duplicate
  • Status changed from accepted to closed

dupe #2639

Note: See TracTickets for help on using tickets.