Opened 3 years ago

Last modified 2 years ago

#3141 new defect

virtualenv.py seems to be required for meta bb installation

Reported by: sa2ajj Owned by:
Priority: major Milestone: sys - other
Version: 0.8.10 Keywords: ansible
Cc: dustin

Description

I saw a reference in the metabbotcfg and copied the file over from old bb.bb.net.

This needs to be covered by the installation procedure one way or another.

Change History (4)

comment:1 Changed 3 years ago by dustin

In fact, all of the Python packages in that directory need to be available. It'd probably be best to put these in a subdirectory on ftp.buildbot.net and just change the URL used in the buildstep.

comment:2 Changed 3 years ago by sa2ajj

I did not find any more packages in the directory itself.

I need to go through the metabbotcfg to see what's actually used.

The console page looks like there's quite a bit to do.

comment:3 Changed 3 years ago by dustin

#3143 for getting the packages online. That's what's causing most of those errors.

There's a lot in that directory!

(sandbox)buildbot@ds0210:~$ ls www/buildbot.buildbot.net/static/pkgs/
astroid-1.0.0.tar.gz            pep8-1.4.6.tar.gz                    Sphinx-1.2.2.tar.gz              Twisted-10.2.0.tar.bz2
boto-2.29.1.tar.gz              pg8000-1.08.tar.gz                   SQLAlchemy-0.6.0.tar.gz          Twisted-11.0.0.tar.bz2
coverage-3.4.tar.gz             pg8000-1.9.14.tar.gz                 SQLAlchemy-0.6.6.tar.gz          Twisted-11.1.0.tar.bz2
decorator-3.3.0.tar.gz          pip-0.8.2.tar.gz                     SQLAlchemy-0.6.8.tar.gz          Twisted-12.0.0.tar.bz2
dicttoxml-1.3.7.tar.gz          pip-1.5.6-py2.py3-none-any.whl       SQLAlchemy-0.7.0.tar.gz          Twisted-12.2.0.tar.bz2
distribute-0.6.15.tar.gz        pip-1.5.6.tar.gz                     SQLAlchemy-0.7.10.tar.gz         Twisted-13.0.0.tar.bz2
docutils-0.7.tar.gz             pyflakes-0.7.3.tar.gz                SQLAlchemy-0.7.4.tar.gz          Twisted-13.2.0.tar.bz2
epydoc-3.0.1.tar.gz             Pygments-1.4.tar.gz                  SQLAlchemy-0.7.8.tar.gz          Twisted-14.0.0.tar.bz2
Flask-0.10.1.tar.gz             Pygments-2.0.1.tar.gz                SQLAlchemy-0.8.0.tar.gz          Twisted-8.1.0.tar.bz2
Ghost.py-0.1b.tar.gz            pylint-1.0.0.tar.gz                  SQLAlchemy-0.8.3.tar.gz          Twisted-8.2.0.tar.bz2
httpretty-0.8.0.tar.gz          pylint-1.1.0.tar.gz                  SQLAlchemy-0.8.6.tar.gz          Twisted-9.0.0.tar.bz2
itsdangerous-0.24.tar.gz        pysqlite-2.6.3.tar.gz                SQLAlchemy-0.9.4.tar.gz          unittest2-0.5.1.tar.gz
Jinja2-2.5.5.tar.gz             python-dateutil-1.5.tar.gz           sqlalchemy-migrate-0.6.1.tar.gz  urllib3-1.8.2.tar.gz
logilab-common-0.60.0.tar.gz    requests-2.3.0.tar.gz                sqlalchemy-migrate-0.6.tar.gz    virtualenv-1.11.6.tar.gz
mock-0.7.0.tar.gz               setuptools-1.4.2.tar.gz              sqlalchemy-migrate-0.7.1.tar.gz  virtualenv.py
mock-0.8.0.tar.gz               setuptools-5.7-py2.py3-none-any.whl  sqlalchemy-migrate-0.7.2.tar.gz  Werkzeug-0.9.4.tar.gz
mock-0.8.0.zip                  setuptools-5.7.tar.gz                sqlalchemy-migrate-0.9.tar.gz    wheel-0.24.0.tar.gz
moto-0.3.1.tar.gz               setuptools-5.8-py2.py3-none-any.whl  Tempita-0.5.2.tar.gz             xmltodict-0.9.0.tar.gz
multiprocessing-2.6.2.1.tar.gz  setuptools-7.0-py2.py3-none-any.whl  Tempita-0.5.3dev.tar.gz          zope.interface-3.6.1.tar.gz
MySQL-python-1.2.3.tar.gz       simplejson-2.1.3.tar.gz              Tempita-0.5dev.tar.gz            zope.interface-4.1.1.tar.gz
ordereddict-1.1.tar.gz          six-1.6.1.tar.gz                     Twisted-10.0.0.tar.bz2
pbr-0.8.0.tar.gz                Sphinx-1.0.7.tar.gz                  Twisted-10.1.0.tar.bz2
(sandbox)buildbot@ds0210:~$ 

comment:4 Changed 2 years ago by dustin

  • Milestone changed from sys - on-bb-infra to sys - other
Note: See TracTickets for help on using tickets.