Opened 6 years ago

Closed 6 years ago

#3140 closed defect (invalid)

traceback in bb.bb.net's twistd.log

Reported by: sa2ajj Owned by:
Priority: major Milestone: 0.8.x
Version: 0.8.10 Keywords:
Cc: dustin

Description

2015-01-06 10:27:50+0000 [HTTPChannel,389,192.168.80.239] Unhandled Error
        Traceback (most recent call last):
          File "/home/bbuser/venv/lib/python2.7/site-packages/twisted/protocols/basic.py", line 571, in dataReceived
            why = self.lineReceived(line)
          File "/home/bbuser/venv/lib/python2.7/site-packages/twisted/web/http.py", line 1656, in lineReceived
            self.allContentReceived()
          File "/home/bbuser/venv/lib/python2.7/site-packages/twisted/web/http.py", line 1731, in allContentReceived
            req.requestReceived(command, path, version)
          File "/home/bbuser/venv/lib/python2.7/site-packages/twisted/web/http.py", line 827, in requestReceived
            self.process()
        --- <exception caught here> ---
          File "/home/bbuser/venv/lib/python2.7/site-packages/twisted/web/server.py", line 184, in process
            resrc = self.site.getResourceFor(self)
          File "/home/bbuser/venv/lib/python2.7/site-packages/twisted/web/server.py", line 706, in getResourceFor
            return resource.getChildForRequest(self.resource, request)
          File "/home/bbuser/venv/lib/python2.7/site-packages/twisted/web/resource.py", line 98, in getChildForRequest
            resource = resource.getChildWithDefault(pathElement, request)
          File "/home/bbuser/venv/lib/python2.7/site-packages/twisted/web/resource.py", line 201, in getChildWithDefault
            return self.getChild(path, request)
          File "/usr/home/bbuser/buildbot/master/buildbot/status/web/olpb.py", line 44, in getChild
            builder = status.getBuilder(path)
          File "/usr/home/bbuser/buildbot/master/buildbot/status/master.py", line 248, in getBuilder
            return self.botmaster.builders[name].builder_status
        exceptions.KeyError: 'builders'

Change History (4)

comment:1 Changed 6 years ago by sa2ajj

Version: 0.8.11-pre-15-g3953a87

comment:2 Changed 6 years ago by dustin

Note that's KeyError, not AttributeError. So name is "builders". What was the URL used here?

comment:3 Changed 6 years ago by sa2ajj

Hmm... I can't reproduce it now.

I was checking the waterfall and console pages when there were no builds performed...

comment:4 Changed 6 years ago by dustin

  • Resolution set to invalid
  • Status changed from new to closed

I suspect this was some URL like /builders/builders, maybe from a confused user or a spider with a stale link. I don't think it's a big deal.

Note: See TracTickets for help on using tickets.