Opened 5 years ago

Closed 5 years ago

#2954 closed defect (fixed)

Notifications not working as they should ...

Reported by: Ben Owned by: tardyp
Priority: patches-accepted Milestone: 0.9.+
Version: master Keywords: web
Cc:

Description

Sometimes, notifications come out of nothing and don't contain any information. I never saw them happening in any other situation.

... Which make me wonder what the intend for such a feature is, but that's more a meta question ...

I just reproduced with nine.buildbot.buildbot.net what is annoying me on my own buildbot install: An empty notification. (see attached screenshot).

Attachments (1)

broken_notification.png (18.0 KB) - added by Ben 5 years ago.
screenshot from nine.buildbot.buildbot.net

Download all attachments as: .zip

Change History (15)

Changed 5 years ago by Ben

screenshot from nine.buildbot.buildbot.net

comment:1 Changed 5 years ago by sa2ajj

  • Milestone changed from undecided to 0.9.+
  • Priority changed from minor to patches-accepted
  • Version changed from 0.8.9 to master

comment:2 Changed 5 years ago by tardyp

Indeed, this is a known bug in guanlecoja-ui.

If you go to the browser's developer console, you will see there is a network error.

comment:3 Changed 5 years ago by Ben

@tardyp: Can you elaborate about the goal for this feature ? It's not clear to me for a end-user point of view why we should display js errors ...

To be honest, I'm quite tempted to remove it all-together as I don't understand which kind of notification a user would like to subscribe to, hence my question ...

comment:4 Changed 5 years ago by tardyp

Indeed, this is a bit experimental. I did not spent a lot of time working on it.

While nine is still in development I find useful to be alerted of network issue or exception in a generic way without having to open the console to make sure.

For medium term, my goal is to inform the user of finished force builds. also, my plan eventually was to make those notification desktop notification using html5 notification api: https://developer.mozilla.org/fr/demos/detail/html5-notifications

comment:5 Changed 5 years ago by Ben

You know what would be great ?

Finally demonstrate the power of interface plugins through offering this feature as a plugin ! Then everyone who don't need it wouldn't need to enable it !

comment:6 Changed 5 years ago by dustin

I think interface plugins are already well-demonstrated, but I think the suggestion to make this a plugin is a reasonable one.

comment:7 Changed 5 years ago by dustin

  • Keywords web added; www removed

comment:8 Changed 5 years ago by tardyp

  • Owner set to tardyp
  • Status changed from new to assigned

comment:9 Changed 5 years ago by Ben

Probably related in some ways:

Error: [ngRepeat:dupes] Duplicates in a repeater are not allowed. Use 'track by' expression to specify unique keys. Repeater: msg in n.notifications, Duplicate key: string:404:not found when:GET api/v2/builders/20/builds/8
http://errors.angularjs.org/1.2.23/ngRepeat/dupes?p0=msg%20in%20n.notificat…g%3A404%3Anot%20found%20when%3AGET%20api%2Fv2%2Fbuilders%2F20%2Fbuilds%2F8
    at http://scaphoid.gb.intevation.de:8020/scripts.js:3:20673
    at http://scaphoid.gb.intevation.de:8020/scripts.js:6:28651
    at Object.r [as fn] (http://scaphoid.gb.intevation.de:8020/scripts.js:5:11826)
    at c.$digest (http://scaphoid.gb.intevation.de:8020/scripts.js:5:12505)
    at c.$apply (http://scaphoid.gb.intevation.de:8020/scripts.js:5:14029)
    at http://scaphoid.gb.intevation.de:8020/scripts.js:5:19963
    at a (http://scaphoid.gb.intevation.de:8020/scripts.js:4:6023)
    at http://scaphoid.gb.intevation.de:8020/scripts.js:4:7746 

But I really would love the ability to switch off the whole feature ...

comment:10 Changed 5 years ago by tardyp

What if I add a way to enable this directly in the UI, with setting stored in browser (disabled by default)

comment:11 Changed 5 years ago by Ben

Please leave the configuration in the master.cfg file at the moment ... We don't need to add yet another abstraction layer there, at least for the moment ...

I believed the ui plugin system was meant for that kind of scenario (leave base as simplistic as possible, and enable extra features on demand). Is it a big no-go to implement notifications that way ?

comment:12 Changed 5 years ago by tardyp

Actually, it is less abstraction layer to store the setting in the browser :) This is why I propose this solution, because it is acually simpler.

As per enabling it in a plugin, like I said, there is no plugin interface for this kind of feature.

There are 2 things that a plugin can do:

  • Add new pages
  • Add new forcescheduler widget.

But there is nothing to actually allow a widget that stays in every pages like the notification. Moreover, I really think that the notification is part of the core-ui, and plugin can make use of it. This is also the reason why it is there and unused. There are other stuff also that are there as PoC, but not used, or without backend. I'll try to clean that up.

I think it is the time to clean unfinished features out of seeing.

comment:13 Changed 5 years ago by Mikhail Sobolev <mss@…>

In efa4ef9b195d955b19249eaf820119b58cb352ba:

Merge pull request #1348 from tardyp/guanlecoja-ui

Use guanlecoja-ui contextual actions for forceschedulers

See ticket:2995, ticket:2954

comment:14 Changed 5 years ago by tardyp

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.