Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#2804 closed defect (wontfix)

Can't change trac.ini

Reported by: dustin Owned by: verm
Priority: major Milestone: sys - other
Version: Keywords:
Cc: rutsky

Description (last modified by verm)

From rutsky

---

I tried to add myself to the list of notified emails when new accounts created/deleted (http://trac.buildbot.net/admin/accounts/notification), but it failed with following error:

    Oops…
    Trac detected an internal error:

    OSError: [Errno 13] Permission denied: '/usr/www/trac/conf/trac.ini-8PAv5t'

    There was an internal error in Trac. It is recommended that you notify your local Trac administrator with the information needed to reproduce the issue.

    To that end, you could a ticket.

    The action that triggered the error was:

    POST: /admin/accounts/notification

Probably there are some issues with Trac files/directories permissions.

Change History (5)

comment:1 Changed 7 years ago by dustin

  • Owner changed from amar to verm
  • Status changed from new to assigned

comment:2 Changed 7 years ago by verm

  • Resolution set to wontfix
  • Status changed from assigned to closed

This is by design, I don't want people changing the INI from the admin interface. It reorders the config which really messes up tracking changes. The config should never need editing from the web interface.

Also, there is a mail alias for these types of notifications already I can add you if you want.

comment:3 follow-up: Changed 7 years ago by verm

  • Description modified (diff)

I added you to the alias just now. It notifies of new users, changes and deletions.

comment:4 in reply to: ↑ 3 Changed 7 years ago by rutsky

Replying to verm:

I added you to the alias just now. It notifies of new users, changes and deletions.

I received test message, so it should work, thanks!

comment:5 Changed 6 years ago by dustin

  • Milestone changed from systems to sys - other

Milestone renamed

Note: See TracTickets for help on using tickets.