Opened 5 years ago

Closed 5 years ago

#2582 closed defect (invalid)

GitPoller requires git >= 1.6.5

Reported by: Quentin Owned by:
Priority: minor Milestone: undecided
Version: master Keywords:
Cc:

Description

GitPoller? uses 'git init directory' instead of 'cd directory && git init'. The former is 'only' available since git 1.6.5, and caused an error with git 1.6.4.4:

exceptions.EnvironmentError?: command failed with exit code 129: usage: git init [-q | --quiet] [--bare] [--template=<template-directory>] [--shared[=<permissions>]]

Feel free to close this ticket if the platforms you are supporting don't have such old git versions (we fixed this by installing git 1.8 in /usr/local). Git 1.6.5 was released in October 2009. For reference, Python 2.6 was released in October 2008.

Change History (1)

comment:1 Changed 5 years ago by Quentin

  • Resolution set to invalid
  • Status changed from new to closed

Oops, the docs mention that GitPoller? requires git >= 1.7. Closing.

Note: See TracTickets for help on using tickets.