Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#2151 closed defect (fixed)

Buildbot adds an wrong argument to bzr command line

Reported by: sleebin9 Owned by:
Priority: major Milestone: undecided
Version: 0.8.5 Keywords: bzr
Cc:

Description

Buildbot checkout step fails. The log says

"bzr: ERROR: extra argument to command checkout: ['-r', u'3730']".

After checked the log, we found buildbot generates a wrong bzr command. It is

bzr checkout bzr+ssh://buildbot@172.16.70.152/data/bzrroot/mysql-server/greatsql-trunk . "['-r', u'3730']"

Attachments (1)

patch-7.diff (1.4 KB) - added by sleebin9 7 years ago.
A patch for the bug

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by sleebin9

A patch for the bug

comment:1 Changed 7 years ago by sleebin9

Buildbot generated a 'bzr checkout' command with an wrong option like

bzr checkout <location> . "['-r', u'3730']"

So buildslave was aborted by the wrong command. It was caused by a wrong function call in bzr.py. List.append appends an object treat. "['-r', self.revision]" is treated as an List object. List object's string output is '[elem1, elem2, ..]'.

To solve the problem, List.extend instead of List.append is used.

comment:2 Changed 7 years ago by Dustin J. Mitchell

  • Resolution set to fixed
  • Status changed from new to closed

Use command.extend to add -r argument to bzr update/checkout

Fixes #2151. Including new tests of all occurrences.

Changeset: 4954bf4fff3163409022d24a60d57506e7306352

comment:3 Changed 7 years ago by dustin

Oops, now that I see your patch, I see that I missed one :)

comment:4 Changed 7 years ago by Dustin J. Mitchell

one additional command.append in bzr.py

Refs #2151.

Changeset: a15f7652817f0ce6fdbff36e14ac4c7b4646f3e0

Note: See TracTickets for help on using tickets.