Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1787 closed defect (fixed)

SVN revision is set to string None if "force build" button is clicked for a builder

Reported by: liucougar Owned by:
Priority: major Milestone: 0.8.4
Version: 0.8.3p1 Keywords:
Cc:

Description

if a builder uses SVN to checkout source code, and "force build" button is clicked on the web ui for the builder, revision property will be set to str(None) instead of python None. this causes something like WithProperty("%(revision)s") fail because it returns "None" instead of ""

this is a regression (at least 0.8.0 works as expected)

the fix is one liner: in file https://github.com/buildbot/buildbot/blob/master/master/buildbot/steps/source.py, insert line "if revision is not None:" before line 'self.setProperty('revision', str(revision), "Source")'

Change History (3)

comment:1 Changed 8 years ago by liucougar

  • Summary changed from SVN revision is set to string None instead if "force build" button is clicked for a builder to SVN revision is set to string None if "force build" button is clicked for a builder

comment:2 Changed 8 years ago by Dustin J. Mitchell

  • Resolution set to fixed
  • Status changed from new to closed

Don't set revision to "None"

As suggested by liucougar. Fixes #1787.

Changeset: dcf667ae0d873b8f145f5f5d9e73429fbcb53265

comment:3 Changed 8 years ago by liucougar

  • Milestone changed from undecided to 0.8.4
Note: See TracTickets for help on using tickets.