Opened 9 years ago

Closed 9 years ago

#1755 closed defect (duplicate)

unable to load bzr_buildbot.py

Reported by: sjl Owned by:
Priority: major Milestone: 0.8.+
Version: 0.8.3 Keywords: bzr
Cc:

Description

copied from the contrib directory.

With 0.8.3, the following patch is needed for it to load. A consequence of this patch is that it will always build the top revision when the buildmaster is (re)started. I tried to change the code to do the same thing it was doing (enumerating over past changes to get the latest revision seen), but encountered exception jungle.

=== modified file 'bzr_buildbot.py'
--- bzr_buildbot.py	2011-01-04 16:47:45 +0000
+++ bzr_buildbot.py	2011-01-05 13:46:20 +0000
@@ -222,6 +222,7 @@
             self.blame_merge_author = blame_merge_author
             self.branch_name = branch_name
             self.category = category
+            self.last_revision = None
 
         def startService(self):
             twisted.python.log.msg("BzrPoller(%s) starting" % self.url)
@@ -240,12 +241,14 @@
                 ourbranch = self.url
             else:
                 ourbranch = self.branch_name
-            for change in reversed(self.parent.changes):
-                if change.branch == ourbranch:
-                    self.last_revision = change.revision
-                    break
-            else:
-                self.last_revision = None
+            
+            #for change in reversed(self.parent.changes):
+            #    if change.branch == ourbranch:
+            #        self.last_revision = change.revision
+            #        break
+            #else:
+            #    self.last_revision = None
+
             self.polling = False
             twisted.internet.reactor.callWhenRunning(
                 self.loop.start, self.poll_interval)

Change History (2)

comment:1 Changed 9 years ago by sjl

Bah, this is a duplicate of #946.

comment:2 Changed 9 years ago by dustin

  • Keywords changesource removed
  • Milestone changed from undecided to 0.8.+
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.