Opened 13 years ago

Closed 13 years ago

#114 closed defect (fixed)

'Stop Build' functionality missing

Reported by: Ukyo81 Owned by:
Priority: major Milestone: 0.7.7
Version: 0.7.6 Keywords:
Cc: Brian, Warner, <warner@…>

Description

The 'Stop Build' button does not seem to appear anymore whether the user sets the AllowForce? attribute of a WebStatus? instance to True.

Steps to reproduce:

  1. Set up a build factory that takes at least a few seconds to finish.
  1. Attach the build factory to a connected buildslave.
  1. Set up a WebStatus? instance with the AllowForce? attribute set to True.
  1. Force a build of that new builder through the web interface.
  1. Navigate back to the build's status page while the build is still in progress.

Results:

The new build's status page does not show a Stop Build button for that build when it is in progress.

Expected Results:

When a builder is building, assuming the WebStatus? instance is set up properly, there should be a 'Stop Build' button available for the user to interrupt the build when necessary. This was the behavior in older builds of buildbot which appears to be missing in 0.7.6.

Change History (2)

comment:1 Changed 13 years ago by Ukyo81

  • Cc Brian Warner <warner@…> added
  • component changed from other to statusplugins-web

comment:2 Changed 13 years ago by warner

  • Milestone changed from undecided to 0.7.7
  • Resolution set to fixed
  • Status changed from new to closed

This ought to be fixed now, in [b2655b2825d52d196f019c2e63d173ced788cbf2]. Thanks!

Note: See TracTickets for help on using tickets.