Opened 14 years ago

Closed 11 years ago

Last modified 11 years ago

#10 closed enhancement (fixed)

Builders should be defined as instances, not as a dictionary

Reported by: warner Owned by: dustin
Priority: major Milestone: 0.7.12
Version: 0.7.5 Keywords:
Cc:

Description

The c['builders'] specification is the last one in master.cfg that is defined with a dictionary. I think it would be much clearer if it were defined as an instance. So instead of:

    b1 = {"name": "svn-hello",
          "slavename": "bot1",
          "builddir": "svn-hello",
          "factory": factory.BuildFactory(steps),
          }
    c['builders'].append(b1)

you would do:

    b1 = Builder("svn-hello", "bot1", factory.BuildFactory(steps))
    Builders.append(b1)

(assuming that #9 was implemented)

Also, the "builddir" argument should go away, and just use the builder name. Having to specify a separate directory is annoying. It might be nice to add a separate "verbose builder name" argument, though, since the normal builder name gets used as a directory name and thus can't have slashes (and really doesn't want to have spaces).

Change History (14)

comment:1 Changed 13 years ago by warner

  • Milestone set to 0.7.7
  • Version set to 0.7.5

comment:2 Changed 13 years ago by warner

  • Status changed from new to assigned

comment:3 Changed 13 years ago by warner

  • Milestone changed from 0.7.7 to 0.7.8

no progress on this yet, bumping to 0.7.8

comment:4 Changed 13 years ago by warner

After finishing this, implement #119 (builder descriptions)

comment:5 Changed 13 years ago by bhearsum

  • Cc bhearsum@… added

comment:6 Changed 13 years ago by warner

also see #148

comment:7 Changed 13 years ago by warner

  • Milestone changed from 0.7.8 to 0.7.9

not happening for 0.7.8, pushing it out.

comment:8 Changed 12 years ago by marcusl

Marked #148 as duplicate of this.

comment:9 Changed 12 years ago by dustin

  • Milestone changed from 0.8.0 to 0.7.+

comment:10 Changed 12 years ago by bhearsum

  • Cc bhearsum@… removed

comment:11 Changed 11 years ago by dustin

  • Milestone changed from 0.8.+ to 0.7.12

This really should get made into an object for the next release - that makes it much easier to add default arguments, etc.

comment:12 Changed 11 years ago by dustin

  • Owner changed from warner to dustin

I'm working on this now -- just rewriting all of the unit tests and the docs.

comment:13 Changed 11 years ago by dustin

  • Resolution set to fixed
  • Status changed from assigned to closed
commit a70a00b22c920ae2c1e95f7bc614a7a94ded861a
Author: Dustin J. Mitchell <dustin@zmanda.com>
Date:   Sat Dec 26 12:13:35 2009 -0600

    (refs #10) add BuilderConfig class, use it in tests, and doc it

comment:14 Changed 11 years ago by Dustin J. Mitchell

use BuilderConfig? in sample.cfg

fixes #923, fixes #10

Changeset: ca9eaece77d2b8c6f3519f981ef69c64b68687a4

Note: See TracTickets for help on using tickets.